No Sentiments/Signals shown in UI for x days

Modified on Tue, 20 Jun 2023 at 05:05 AM

Problem

Customer reports that they don't see any sentiments/signals showing up in the UI for "x" number of days.


Possible Causes

  • Filters set in Global and Dynamic filters
  • Data Sync issue where there are no new cases ingested into SupportLogic.
  • Ontology settings
  • Recent deployments


Validation Steps:

  • From your login, on Console page --> check if you can see any sentiments/signals for reported period.

  • Check Sentiments page to see if there any sentiments recorded for the reported period.


Note:
Case status should be set to "All". 
Include all sentiments. 
Zoom out to see the wider date range to see the trend



Check in the DB to confirm if it is a problem in backend or frontend


  • In SuperSet, execute the below query to find the sentiment count.


select count(signal_count) from labeler_signal_counts where dim_date between '2023-06-14' and '2023-06-20' AND subdomain = 'bandwidth'
Change the date and customer name accordingly
  • If the customer name is not listed in SuperSet, you have to check this on Pipe DB.


  • In Pipe DB, use the below query to find the last recorded sentiment count.


select max(s_created_at) from span_doc_diverse;

If there is no count showing for a date or if the last signal detected date is old, then raise a bug ticket with all these information.


NOC will check the diverse_v3 container logs and restart if required


Solutions

  • If there are no logs on diverse_v3 container and if the memory usage of this service is very low, it indicates an issue here.
  • NOC will restart the container to resolve this issue.


Additional Information

  • Always raise this Bug as Urgent/Critical and post a note in DevOps tagging NOC.
  • After diverse_v3 restart, sentiments will pickup slowly. You should start seeing the sentiments
Sample Case: https://supportlogic.atlassian.net/browse/SLC-34494

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